Cosa serve per installare Drupal

di Michele Costanzo Commenta

Drupal Logo
Drupal è un Content Management System molto noto ed apprezzato che fa della sua flessibilità d’uso uno dei suoi punti di forza. In questo post esamineremo alcune caratteristiche generali di questa piattaforma ed i requisiti tecnici necessari alla sua installazione lato server.

Drupal vs WordPress

Data la grande diffusione registrata da WordPress può essere utile anzitutto fare un breve confronto con Drupal. Fermo restando che esistono anche in questo settore preferenze personali che possono orientare in un senso o nell’altro la scelta del CMS, in genere WordPress è considerato più semplice da installare ed amministrare ma anche più limitato nei campi di impiego.

Mentre infatti WordPress ha come obiettivo primario la creazione di blog, Drupal è pensato per creare siti più complessi di cui eventualmente il blog costituisca solo una sezione. Per i più tecnici diciamo anche che generalmente Drupal è considerato più scalabile di WordPress, vale a dire che può essere adattato facilmente a progetti di differenti dimensioni o di cui è prevista una evoluzione significativa nel tempo.

I requisiti di Drupal

Attualmente vengono sviluppati diversi rami paralleli di Drupal. Il ramo Drupal 7.x è quello attualmente più importante ed offre un set di funzioni molto ricco. Il ramo 6.x invece offre continuità alla generazione precedente del CMS. E’ in pieno sviluppo anche il ramo 8.x che introdurrà numerose novità tecniche.

L’installazione lato server di Drupal richiede pochi requisiti fondamentali:

  • Uno spazio minimo di 15 MB (ma lo spazio necessario dipende ovviamente anche dal tipo di progetto).
  • Un webserver tra Apache, Nginx, o Microsoft IIS.
  • Un database (MySQL 4.1 o successivo, PostgreSQL 7.1 o successivo per Drupal 6) (MySQL 5.0.15 o successivo con PDO, PostgreSQL 8.3 o successivo con PDO, SQLite 3.3.7 o successivo per Drupal 7).
  • Il supporto per PHP (PHP 4.4.0 o successivo con raccomandazione per PHP 5.2 per Drupal 6) (PHP 5.2.5 o successivo con raccomandazione per PHP 5.3 per Drupal 7) (PHP 5.4 o successivo per Drupal 8).

Ulteriori dettagli sui requisiti minimi di Drupal sono inoltre disponibili sul sito ufficiale del progetto.

[Photo Credits | Drupal.org]

Lascia un commento

Il tuo indirizzo email non verrà pubblicato.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>